• Topic
  • Discussion
  • SupportWeb.TechnicalFAQs(Last) -- Owiki? , 2016-08-19 14:59:38 Edit owiki 2016-08-19 09:59:38

    Technical Frequently Asked Questions

    See Also: Mac FAQ, Support Services FAQ

    Database Support

    Do you connect to Access .mdb files hosted on Linux or other non-Windows systems?

    No. Our UDA components can only provide connection to a .mdb file if it is hosted on a Windows operating system with a full Access install.

    Do you connect to DB2 on OS/400 or AS/400?

    Yes. We do not build components for installation on OS/400.

    To establish connectivity to DB2 on OS/400, you can install our DB2-specific components (Single-Tier "Lite" Edition ODBC Driver or Multi-Tier "Enterprise" Edition Database Agent) on any supported operating system that has a functional copy of DB2 client networking (currently and historically called "DB2 Connect").

    You can also use our Bridges to JDBC, in combination with the open source JT/Open (formerly known as JT400) components made available by IBM.

    Do you support Oracle 10i on Windows Opteron AMD (x64_86)?

    At the time of writing, we have Multi-Tier, Single-Tier (Lite), and Single-Tier (Express) drivers that connect to 32-bit Oracle 10i on Windows x86_64. We have Single-Tier (Express) drivers for 64-bit Oracle DBMS on Windows x86_64. Other driver formats are planned.

    Do you support Progress 9.1E?

    Yes! For best results, we recommend that you update to Progress 9.1E04 or later.

    Do you support Progress OpenEdge 10.x or 11.x?

    Yes!

    Operating System Support

    Do you support AIX 5.3? What about AIX 6.x or AIX 7.x?

    We provide 32-bit and 64-bit components built with AIX 5.2 and AIX 5.3. All of these are binary compatible with AIX 6.x and 7.x.

    Our 32-bit builds for AIX 4.x are also binary compatible with AIX 5.x, AIX 6.x, and AIX 7.x.

    Do you support Mac OS X 10.5 (Leopard)? Mac OS X 10.6 (Snow Leopard)? Mac OS X 10.7 (Lion)? Mac OS X 10.8 (Mountain Lion)?

    We build and brand components for Leopard which are fully compatible with all later versions to date, through Mac OS X 10.8.2.

    Our builds for Mac OS X 10.4 (Tiger) may also be used with Mac OS X 10.5, should a Leopard-specific build not be immediately available.

    Licenses

    Do you license by chip or by core?

    We license components by physical core. Software hosted on a machine with a single quad-core CPU, or with two dual-core CPUs, or four single-core CPUs, would require a 4 core license.

    Can I download licenses from your site?

    Yes. You can purchase permanent license keys using our online Shopcart. The Shopcart will email the keys to you. You will receive a 15 day temporary key when you first download our software. A second, 15 day key will be stored in your ODS DAV repository.

    How long do driver evaluation periods last?

    Our evaluation period lasts 15 days.

    Can I obtain a Single-User (1/1) license for Multi-Tier?

    Our smallest Multi-Tier license supports up to 5 total concurrent database sessions, from up to 5 concurrent client hosts.

    Can I deploy licenses from two different software releases on the same machine?

    You can deploy two commercial or evaluation licenses from different releases on the same machine. On Unix be sure to set your OPL_LICENSE_DIR variable to point to the correct directory location before starting any service associated with our components.

    If you are deploying Release 6.x+ on the same host as a legacy release, be sure to start all services associated with the legacy installations, before you start any services associated with Release 6.x.

    How do I know which license file is being used?

    Use our HTTP-based tools to detect the license in use.

    General Configuration

    How do I obtain start-up scripts for your Multi-Tier Server Components?

    Our support team does not write start-up scripts for products in the Product Portfolio. Start-up scripts must be carefully crafted and customized to guarantee proper functionality in the target environment. Professional Services can write such start-up scripts for a fee. Product Support can provide a template which customers and evaluators may modify for their own environments.

    Progress Connectivity

    Can I establish SQL-89/4GL connections to Progress OpenEdge 10?

    We cannot enable SQL-89/4GL connectivity to Progress OpenEdge 10.0A or later. This is due to limitations in the Progress Development libraries that we use to build Progress agents and drivers.

    SQL-92 connections to OpenEdge 10.0 and later are fully supported.

    Can I connect to Progress 9 & OpenEdge 10 databases running on the same machine?

    Yes. This is simply a matter of configuring the environment and .ini files associated with our products. Contact Product Support for additional guidance.

    Common Error Messages and Links to Solutions


    Referenced by...